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Abstract:  

COMSOL Multiphysics software, when properly 

configured, can readily solve modeling problems 

in the laminar flow regime using the standard 

Navier-Stokes equations or in the fully turbulent 

flow regime using the kappa-epsilon model. 

Failure to solve a particular model is typically 

manifested by instability in the calculation and a 

failure of the model to converge. 

 

This paper presents a new approach to achieving 

a convergent model solution through the 

reconfiguration of the shape of the modeled 

geometry. This shape-oriented approach 

stabilizes the convective flow and allows use of 

the standard Navier-Stokes equations.  
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1. Introduction 
 

The models presented in this paper employed 

the COMSOL Multiphysics software and the 

Heat Transfer Module. The models developed 

and presented herein are 2D axially symmetric 

models of differently configured, dual-layer, 

insulated, heated, water tanks. The purpose of 

the information presented in this paper, through 

use of these models, is to demonstrate a first 

principles approach to the building and running 

of these models. A first principles approach was 

used to modify the modeling parameters and the 

tank geometry, so that the model was able to 

achieve convergence, in the typically difficult 

Navier-Stokes (NS) laminar flow environment. 

 

The models presented in this work represent 

an expansion and modification of the approach 

to solution contained in two of the COMSOL 

Heat Transfer Module Model Library Models 

[1,2]. In the work contained herein, the primary 

factors that have been changed are the geometry 

of each of the six models, some of the boundary 

conditions and also certain meshing and solver 

parameters, to achieve model convergence in the 

potentially difficult NS modeling regime. 

 

2. First Principles Applied to Fluid Flow 
 

Calculation of fluid flow behavior is a 

complex and difficult area to model. The 

modeled behavior (free convection) of the fluid 

(air, in this case) depends highly on the external 

force (gravity, herein), the properties of the fluid 

(thermal conductivity, density, density gradient, 

viscosity, etc.) and the relative direction of the 

temperature gradient [3].  

 

In a First Principles Analysis, analytical 

consideration needs to be used to determine 

which factors (materials properties, geometry, 

etc.) in the model in question predominantly 

contribute to the generation of unstable regions 

in these models that are presumed to have 

nominally laminar flow patterns.  

 

In a free convection situation, the flow of air, 

laminar and/or turbulent, is driven by the 

temperature differential, the differential density, 

the geometry of the flow path and the 

gravitational force. For short path lengths, the 

gravitational force is substantially constant and is 

so treated in this paper. The primary driving 

force of the airflow (free convection) mechanism 

in this model is the temperature of the material in 

the tank (water). In this 2D Axisymmetric 

model, the surface geometry (shape) of the top of 

the tank is the primary factor that contributes to 

the creation of turbulence in the nominally 

laminar free convection airflow patterns.  

 

 In this paper, the temperature gradient is 

generated by heat leakage through the wall of the 

insulated tank. The turbulence in the free 

convection airflow is created by the degree of 

abruptness in the geometrical configuration of 

the tank. The free convection currents in the 

models reported herein comply with the laminar 

assumption (percent laminar versus percent 

turbulent) to a reasonable degree.  This allows 

most of the models to converge to solution. The 

geometrical shape of the top of the tank is 

changed from model to model. This change is 

the predominant factor that dictates the degree to 
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which convergence is achieved (residual error 

being adjusted).  

 

For those tanks with the most abrupt change 

of curvature (slope) between sidewall and the 

top, convergence fails. The First Principle 

dictating that those models will fail to converge 

stems from the basic physics of fluid flow. Local 

instability (mostly laminar flow plus a few 

percent turbulent flow) is directly induced in the 

flow pattern as a function of the curvature of the 

top surface, in the region closest to both the axis 

of the model and the top of the tank. As a result 

of this local instability, the calculated values for 

the properties of the convected material in the 

models (air, in this case) fail to stabilize in those 

regions of the models. Such instabilities are the 

result of the rotational/chaotic behavior imparted 

to the free convection current as it rises and 

expands beyond the vertical termination of the 

tank wall. 

 

A comparative analysis of the results derived 

by modeling the same tank (dimensionally), with 

differently shaped tops is presented below. This 

analysis shows that there exists a mathematical 

boundary below which convergence fails. 

 

3. Building the 2D Axisymmetric Model 

 
This modeling calculation in this paper 

employs a two-stage process. The first stage 

develops a model derived from the “thermos 

laminar hcoeff” model in the COMSOL Heat 

Transfer Module Model Library, Tutorial 

Models folder. The first stage model is the 

starting point for the second stage free 

convection model based on the COMSOL, Heat 

Transfer Module, Model Library, Tutorial 

Models, “thermos laminar flow”. In this paper, 

detailed instructions for the building of one of 

the convergent two-stage models will be 

presented. The building of other models of 

different shapes is presented in the form of 

tabular guidelines, due to space limitations in 

this presentation. 

 

3.1 The First Model: Creating the Water 

Tank 
 

Start, by opening the COMSOL Multiphysics 

Model Navigator. Select: Axial symmetry (2D). 

 

 Next, Select: 

Heat Transfer Module>General Heat 

Transfer>Steady-state analysis>Click OK. 

 

To create the Control Volume (airflow region), 

Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.25, 

Height=0.55>Click OK>Click Zoom Extents. 

 

Creating the insulated water tank is a multi-step 

process. The first step is to create the outer-shell. 

 

1. Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.15, 

Height=0.25>Click OK 

 

2. Select: Draw>Specify Objects>Ellipse.  

Enter in the edit windows: A-semiaxes=0.15, B-

semiaxes=0.15>z=0.25>Click OK 

 

3. Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.15, 

Height=0.4>r= -0.15>Click OK 

 

4. Select: Draw>Create Composite Object.  

In the Set formula edit window, 

Enter: E1-R3>Unselect Keep Interior 

Boundaries>Click OK. 

 

5. Select: Draw>Create Composite Object.  

In the Set formula edit window, 

Enter: R2+CO1>Unselect Keep Interior 

Boundaries>Click OK. 

 

Steps 1>5 yield CO2. 

 

The outermost layer of the water tank has been 

formed. The next step is to create the inner 

boundary of the metallic outer shell (0.0025m). 

 

6. Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.15-0.0025, 

Height=0.25-0.0025>z=0.0025>Click OK 

 

7. Select: Draw>Specify Objects>Ellipse.  

Enter in the edit windows: A-semiaxes=0.15-

0.0025, B-semiaxes=0.15-0.0025>z=0.25>Click 

OK 

 

8. Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.15, 

Height=0.4>r= -0.15>Click OK 



9. Select: Draw>Create Composite Object.  

In the Set formula edit window, 

Enter: E1-R3>Unselect Keep Interior 

Boundaries>Click OK. 

 

10. Select: Draw>Create Composite Object.  

In the Set formula edit window, 

Enter: R2+CO1>Unselect Keep Interior 

Boundaries>Click OK. 

 

Steps 6>10 yield CO3. 

 

The inner boundary of the metallic outer shell 

has been formed. The next step is to form the 

inner boundary of the insulation layer (0.01m). 

 

11. Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.15-0.0025-

0.01, Height=0.25-0.0025-

0.01>z=0.0125>Click OK 

 

12. Select: Draw>Specify Objects>Ellipse.  

Enter in the edit windows: A-semiaxes=0.15-

0.0025-0.01, B-semiaxes=0.15-0.0025-

0.01>z=0.25>Click OK 

 

13. Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.15, 

Height=0.4>r= -0.15>Click OK 

 

14. Select: Draw>Create Composite Object.  

In the Set formula edit window, 

Enter: E1-R3>Unselect Keep Interior 

Boundaries>Click OK. 

 

15. Select: Draw>Create Composite Object.  

In the Set formula edit window, 

Enter: R2+CO1>Unselect Keep Interior 

Boundaries>Click OK. 

 

Steps 11>15 yield CO4. 

 

The inner boundary of the metallic outer shell 

has been formed. The next step is to form the 

inner boundary of the inner metallic shell 

(0.0025m). 

 

16. Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.15-0.0025-

0.01-0.0025, Height=0.25-0.0025-0.01-

0.0025>z=0.015>Click OK 

17. Select: Draw>Specify Objects>Ellipse.  

Enter in the edit windows: A-semiaxes=0.15-

0.0025-0.01-0.0025, B-semiaxes=0.15-0.0025-

0.01-0.0025>z=0.25>Click OK 

 

18. Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.15, 

Height=0.4>r= -0.15>Click OK 

 

19. Select: Draw>Create Composite Object.  

In the Set formula edit window, 

Enter: E1-R3>Unselect Keep Interior 

Boundaries>Click OK. 

 

20. Select: Draw>Create Composite Object.  

In the Set formula edit window, 

Enter: R2+CO1>Unselect Keep Interior 

Boundaries>Click OK. 

 

Steps 16>20 yield CO1. 

 

Next, the volume occupied by the water is 

created. 

 

21. Select: Draw>Specify Objects>Rectangle.  

Enter in the edit windows: Width=0.15-0.0025-

0.01-0.0025, Height=0.25-0.0025-0.01-

0.0025>z=0.015>Click OK 

 

22. Select: Draw>Create Composite Object.  

In the Set formula edit window, 

Enter: CO2+CO3+CO4+CO1+R2 >Select 

Keep Interior Boundaries>Click OK. 

 

Select: File>Save 

 

3.2 The First Model: Constants 

 

Select: Options>Constants 

Enter the following values: 

 
k_insul 0.01[W/(m*K)]  Insulation k 

p_atm  1[atm]    Air pressure  

Length 0.4[m]    Height of tank  

T_water 95[degC]   Water Temp. 

T_amb 20[degC]   Ambient Temp. 

rho_insul  60[kg/m^3]  Density Insul. 

Cp_insul 200[J/(kg*K)]  Heat Capacity 

Length2 0.15[m]   Width of Tank 

 



Where Length and Length2 are the projected 

height of the vertical wall and width of the 

horizontal top of the water tank, respectively.  

 

Save the Constants file for use in the other 

shape related models. The constant Length will 

need to be adjusted to the appropriate projected 

value as different size elliptical tops are created 

for different models. 

 

3.2 The First Model: Heat Transfer (HT) 

Subdomain Settings 

 
Select Physics>Subdomain Settings 

 

Select from Subdomain selection window, 

Subdomains 4 and 6, clear the Active in this 

domain check box, 

 

Enter the following values in the 

Subdomain Settings edit window: 
 

Subdomain # Basic Materials Library (BML) 

1    BML Load: Structural Steel 

2    Constants: Insulation Properties 

    k_insul 

    rho_insul 

    Cp_insul 

3    BML Load: Structural Steel 

5    BML Load: Air 

 

In the density expression for Air, replace p with 

p_atm. 

 

3.3 The First Model: Boundary Settings 

 
Select: Physics>Boundary Settings 

 

Select: Boundaries 8, 14, and 20 in the 

Boundary selection window. Change the 

Boundary condition to Temperature. Enter 

T_water in the T0 edit window. 

 

Select: Boundary 23 in the Boundary selection 

window. Change the Boundary condition to 

Heat Flux. Load the Nat. Vertical Wall … into 

the h (Heat transfer coefficient) edit window. 

Change L_htgh to Length. Enter T_amb in the 

Tinf edit window. 

 

Select: Boundary 29 in the Boundary selection 

window. Change the Boundary condition to 

Heat Flux. Load the Nat. Horiz. Plane, Upside 

… into the h (Heat transfer coefficient) edit 

window. Change L_htgh to Length2. Enter 

T_amb in the Tinf edit window. 

 

3.4 The First Model: Mesh and Solve 

 
Click Solve 

 

Now that the first model is solved, Select: File > 

Save and save the solved model under a new file 

name. 

 

3.4 The Second Model: Adding Navier-

Stokes (N-S) 
 

Open the new model. Select 

Multiphysics>Model Navigator>Heat 

Transfer Module>Weakly Compressible 

Navier-Stokes>Steady-state analysis>Click 

Add>Click OK. 

 

Select: Options>Expressions>Scalar 

Expressions. Enter the following expressions: 

Name   Expression 

F_bouyancy 9.81[m/s^2]*(rho_air_ref-

rho_chns) 

 

rho_air_ref  mat2_rho(p_atm[1/Pa], 

T_amb[1/K])[kg/m^3] 

 

3.5 The Second Model: N-S Subdomain 

Settings 

 
Select Physics>Subdomain Settings 

 

Select from Subdomain selection window, 

Select Subdomains 1 – 5 clear the Active in this 

domain check box, Click Apply  

 

Select from Subdomain selection window, 

Select: Subdomain 6> Select Air from the 

Library material list. Enter F_bouyancy in 

the Fz edit window. Click the Density tab. 

 

Replace rho(p[… with rho((p+p_atm)[…, 

Click Apply. 

Select the Pressure p and Temperature 

check boxes. Enter T in the Temperature 

edit window. Click OK. 



3.5 The Second Model: Physics Settings 

HT Subdomain Settings 

 
Select: Multiphysics>General Heat 

Transfer>Physics>Subdomain settings. 

 

Select from Subdomain selection window, 

Select: Subdomain 6> Select the Active in this 

domain check box. Select Air from the Library 

material list. Click the Convection tab. Select 

the Enable convective heat transfer check box. 

 

Replace rho(p[… with rho((p+p_atm)[… 

In the Density edit window. Click Apply 

 

Enter u and v in the Velocity field edit windows. 

 

Click the Artificial Diffusion button. Select the 

Streamline diffusion check box. Select 

Galerkin least-squares (GLS) from the list. 

Click OK> Click OK. 

 

HT Boundary Conditions 
 

Select: Multiphysics>General Heat 

Transfer>Physics>Boundary Settings. 

 

Select Boundary 18 from the Boundary 

selection window, set the Boundary condition 

to Axial symmetry. 

 

Select Boundary 19 from the Boundary 

selection window, set the Boundary condition 

to Convective flux. 

 

Select Boundary 24 from the Boundary 

selection window, verify that the Boundary 

condition is set to Thermal insulation. 

 

Select Boundary 25 from the Boundary 

selection window, set the Boundary condition 

to Temperature. Enter T_amb in the T0 edit 

window. Click OK. 

 

N-S Boundary Conditions 
 

Select Multiphysics> Weakly Compressible 

Navier-Stokes> 

 

Select Boundary 18 from the Boundary 

selection window, set the Boundary type to 

Symmetry boundary and the Boundary 

condition to Axial symmetry. 

 

Select Boundary 19 from the Boundary 

selection window, set the Boundary type to 

Outlet, the Boundary condition to Normal 

stress and f0 to 0. 

 

Select Boundary 25 from the Boundary 

selection window, set the Boundary type to 

Open boundary, the Boundary condition to 

Normal stress and f0 to 0. 

 

Confirm that Boundaries 23, 24, and 29 have a 

Boundary type of Wall and a Boundary 

condition of No slip. Click OK. 

 

3.6 The Second Model: Meshing  
 

Select: Mesh>Free Mesh Parameters 

Select the Subdomain tab 

In the Subdomain selection window, select 

Subdomain 6 > Enter 0.005 in the Subdomain 

mesh parameters edit window> Select Quad> 

Click the Remesh button>Click OK 

 

3.6 The Second Model: Solving  
 

Select: Solve>Solver Parameters 

Click the Stationary tab 

Select the following Check boxes: 

Damped Newton, Highly nonlinear problem, 

Manual tuning of damping parameters. 

 

Enter the following parameters: 

Relative tolerance   1.0E-2 

Maximum … iterations  50 

Initial damping factor  1.0E-4 

Minimum damping factor 1.0E-12 

 

Click on the Advanced tab 

Type of scaling    none 

Click OK 

 

Select Solve 

 

3.7 The Second Model: Postprocessing  
 

Select: Postprocessing>Plot Parameters 

 

In the Plot Parameters window, Click the 

General tab. 



Select the following check boxes: Surface, 

Streamline, and Geometry Edges. 

 

In the Surface window, Select the Surface Plot 

check box. Select the Surface Data tab. Select 

Temperature from the Predefined quantities 

list and Select degC from the Unit: list. 

 

Select the Streamline tab. In the Streamline 

window, Select the Streamline plot check box. 

Select the Streamline Data tab. Select: Weakly 

Compressible Navier-Stokes>Velocity field 

from the Predefined quantities list. Select: 

Magnitude controlled from the Streamline plot 

type list. 

Click OK. 

 

Result of the above modeling effort of a Water 

Tank Top with Aspect Ratio 1.0 is as shown in 

Figure 1 below. 

 

 
Figure 1 Water Tank Top Aspect Ratio 1.0 

 

4.0 The Second Model: Shape Variation 

Influence on Convergence and Solution(s)   
 

Six different N-S models were built and run to 

determine the influence of the curvature of the 

elliptical top of the water tank on the 

convergence of the solution of the COMSOL 

Multiphysics model in the Control Volume. Each 

of the models built had an elliptical top with a 

different combination of A-semiaxes and B-

semiaxes values. Those values are shown in 

Table 1 below. 

Model# A  B  B/A Convergence 

1  0.15 0.15 1   Yes 

2  0.15 0.20 1.33  Yes 

3  0.15 0.05 0.33  Yes 

4  0.15 0.03 0.20  No 

5  0.15 0.04 0.267  Yes 

6  0.15 0.033 0.22  Yes 

 

The results of these calculations are shown 

in Figures 2-6 below. 

 

 
Figure 2 Water Tank Top Aspect Ratio 1.33 

 

 
Figure 3 Water Tank Top Aspect Ratio 0.33 

 

A binary search was run on Convergence vs. 

Aspect Ratio. The results of that search show 

that models with Aspect Ratios > 0.22 converge. 

Models with Aspect Ratios < 0.20 do not 

converge. The streamline modeling results are 

shown in Figures 6 and 4, respectively. 



 

 
Figure 4 Water Tank Top Aspect Ratio 0.20 

 

 
Figure 5 Water Tank Top Aspect Ratio 0.267 

 

 
Figure 6 Water Tank Top Aspect Ratio 0.22 

 

Please note the deviations (double-valued loops) 

from the nominally normal flow patterns 

exhibited close to the 2D-axis at the top of the 

tank and also close to the bottom of the tank near 

the tank wall in Figure 4. 

 

Solver tuning was achieved through adjustment 

of the Relative tolerance, the Maximum number 

of iterations, and the addition of Manual tuning 

of damping parameters. 

 

7. Conclusions 
 

Through careful adjustment of a modeled 

object’s shape and proper tuning of a model’s 

solver parameters, a modeler can, in many cases, 

obtain convergence in Navier-Stokes convection 

models that nominally fail to converge. 
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