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Abstract: This paper presents a new phase 
transition model that is easily created and runs 
rapidly. It is designed so that the modeler can 
determine immediately the relative accuracy of 
the end result by use of physics first principles. 
Phase transitions are readily observable in many 
commonly utilized engineering materials. In fact, 
most modern devices and/or tools employ a 
phase transition in their manufacture. This model 
demonstrates the ease of use that is inherent in 
COMSOL model development. This model 
builds on earlier COMSOL phase transition 
modeling examples.  
 
Examples are presented here of variations in the 
model parameters by using four different eutectic 
metal alloys in separate model runs. Such alloys 
are commonly employed to achieve both a strong 
mechanical contact and a high conductivity 
electrical contact. Variations of this model will 
allow the tracking of the phase boundary as a 
function of time. 
 
Keywords: phase transition, soldering, brazing, 
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1. Introduction 
 

The COMSOL Multiphysics model 
developed and presented in this case is a 2D 
axially symmetric model of a hollow metallic 
disk with quasi-static radial material flow 
outward from the axis. This model is used to 
demonstrate how the correct position of the 
phase boundary can be determined by inspection 
through the use of physics first principles. It also 
shows how these results are related to the 
geometry and the boundary condition of the 
model. This model was developed through 
reference to the modeling techniques developed 
in the Continuous Casting Model in the Heat 
Transfer Module Guide [1].  
 
 

1.1 The Materials Modeled 
 
The metallic materials [2] chosen as examples 
for use in this model are listed in Table 1 below: 
{(E) indicates a eutectic alloy} 
 
Solder Bi In Sn Pb Zn 

 % % % % % 
BiPb(E) 55.5 0 0 44.5 0 
BiSn(E) 58 0 42 0 0 

In 0 100 0 0 0 
SnPb(E) 0 0 63 37 0 
SnZn(E) 0 0 91 0 9 
 
Table 1 Lead Free Eutectic Solders, Indium, Tin 
Lead and Bismuth Lead Eutectic Solders 
 
These particular metallic phase change example 
materials were chosen for use in this model 
because they are widely used in electronic and 
mechanical industrial processes. 
 
1.2 The Physics 
 
In a phase change transition, all of the properties 
of the material in question change, some by a 
small amount, others significantly. The most 
obvious material property change is the liquid-
solid or solid-liquid transition and the related 
structural and mechanical property changes. Less 
obvious and possibly less familiar property 
changes are those phase change related 
differences that are exhibited in the thermal and 
electrical characteristics of such materials. These 
property changes are induced by the order-
disorder transition that occurs in the solid-liquid 
or vice versa in the liquid-solid phase transition. 
Knowledge of such phase change induced 
structural, mechanical, thermal, electronic and 
related property changes and their associated 
shifts in the related magnitude and temperature 
(T) dependence are critically important for the 
formulation of accurate FEA models. 
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Both the heat capacity and the thermal 
conductivity of the eutectic metal alloys in the 
range discussed in this paper (380K- 480K) are 
dominated by electron energy transport. 
Experimentally, in this temperature range for 
these materials, the heat capacity can be 
expressed as: 
 

! 

1.  C = !T + AT3   
where !  and A are material specific constants [3] 
and the phonon contribution (AT3) is very small 
compared to the electron contribution. 
 
The thermal conductivity (K) is related to the 
heat capacity per unit volume as: 
 

2. K = 

! 

1

3
 Cvl     

where C is the heat capacity per unit volume, v  
is the electron velocity and l  is the mean free 
path [4]. 
 
1.3 The Materials 
 
The materials chosen as examples in this model 
are four eutectic alloys and one pure metal (In). 
A eutectic alloy [5,6] is a mixture of two or more 
materials that when combined have the lowest 
possible melting point for that composition. All 
the alloys chosen for this model are binary (two 
components) alloys. 
 

        
 
Figure 1. Tin-Lead Phase Diagram (after [5]) 
 
Also, that unique eutectic alloy composition 
transforms directly from a solid to a liquid or 
vice versa, without passing through a mixed 
composition (solid/liquid {mushy}) phase, as 
shown for Tin-Lead in Figure 1 above. 

The lack of a mushy phase at the eutectic point 
results in a more abrupt transition. However, for 
ease of modeling in an FEA based system and to 
achieve rapid convergence, the eutectic materials 
and the metal in this model are treated as if they 
each have a narrow liquid-solid transition zone. 
 
2. The Model 
 
This model is configured in COMSOL 
Multiphysics as a 2D axisymmetric model with a 
phase change transition.  
 

 
 
Figure 2. 2D Axisymmetric Phase Transition Disk 
Model 
 
Figure 2 above shows the COMSOL modeling 
window, as configured for the 2D Axisymmetric 
Phase Transition Disk Model. 

 
Figure 3. Toroidal Disk Modeled 
 
Figure 3 above shows an off-axis view of the 
modeled flat toroidal disk. 
 
The radial location of the phase transition is a 
function of the transition temperature (T_trans) 
of the particular binary eutectic alloy or metal 
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and the temperature differential between the 
inner radial boundary and the outer radial 
boundary 
 
2.1 Setting Up the Model Constants 
 
The model window, as shown in Figure 2 above, 
is established by opening the Model Navigator 
and clicking the New tab. In the Space 
dimension list, select Axial symmetry (2D). 
From the list of application modes, select the 
Heat Transfer Module>Fluid-Thermal 
Interaction>Non-Isothermal Fluid-Thermal 
Interaction>Steady-state Analysis and then 
click OK (after [1]). 
 
Open the Options menu and select the 
Constants window.  The column values 
associated with each metal in the following 
tables are entered as a group in separately 
created copies of this model for each unique 
material.  
 
The first model was built using the BiSn material 
and thus the bisn subscript. When a model is run 
for a different material, the subscript can remain 
the same and only the name of the model needs 
to be changed, to avoid confusion in analyzing 
the results.  
 

Solder BiPb BiSn In 
Variables    

T0 300 300 300 
T_in 480 480 480 
T_out 380 380 380 

dT 0.5 0.5 0.5 
dH 20.9[J/g] 44.8 ‡ 28.47 ‡ 

Cp_bisn 0.126[J/g*C] 0.167 ‡ 0.243 ‡ 
rho_bisn 10.44[g/cm^3] 8.56 ‡ 7.31 ‡ 
T_trans 397.15 411.15 430.15 
u_cast 1e-5 1e-5 1e-5 

eta_bisn 0.01 0.01 0.01 
k_bisn 0.04[W/cm*C] 0.19‡ 0.86‡ 

 
Table 3 Constants for the First Three Phase 
Transition Materials (in the case of omitted units, 
they are the same ‡ as for the first member of the 
row; otherwise they are the default SI units). 
 
Figure 4 below shows an example of the 
Options > Constants window as filled in for the 
Bismuth (Bi58) – Tin (Sn42) solder. 
 

 
 
Figure 4 Options > Constants window for Bi58Sn42 
Eutectic Solder 
 

Solder SnPb SnZn 
Variables   

T0 300 300 
T_in 480 480 
T_out 380 380 

dT 0.5 0.5 
dH 45.0[J/g] 71.2[J/g] 

Cp_bisn 0.167[J/g*C] 0.239[J/g*C] 
rho_bisn 8.4[g/cm^3] 7.27[g/cm^3] 
T_trans 456.15 472.15 
u_cast 1e-5 1e-5 

eta_bisn 0.01 0.01 
k_bisn 0.50[W/cm*C] 0.61[W/cm*C] 

 
Table 4 Constants for the Last Two Phase 
Transition Materials (units are as shown; otherwise 
they are the default SI units). 
 
2.2 Setting Up the Model Scalar Expressions 
 

 
 
Figure 4 Scalar Expressions Window 
 
Open the Options menu and select the 
Expressions >  Scalar Expressions. Once filled 
in as shown in Table 5 below, it will appear as 
shown in Figure 4 above.  
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Variable Expression 

D exp(-(T-T_trans)^2 
/(dT^2))/sqrt(pi*dT^2) 

B (T-T_trans+dT)/(2*dT)* 
((T<=(T_trans+dT))* 
(T>=(T_trans-dT))) 
+(T>(T_trans+dT)) 

Sr (1-B)^2/(B^3+1e-3)*1e5* 
(u-u_cast) 

Sz (1-B)^2/(B^3+1e-3)*1e5*v 
Cp1 Cp_bisn+dH/T_trans*H 
H flc2hs(T-T_trans,dT)  

 
Table 5 Scalar Expressions  
 
The expressions in Table 5 are the same as 
shown in the Continuous Casting example [1] for 
D, B and H. The expressions for Sr, Sz and Cp1 
have been modified as shown. In the case of 
Cp1, Cp_bisn replaces the value “380”. That 
substitution allows value changes to be required 
only in the Constants window in order to explore 
the use of different materials in the same physics 
model. 
 
2.3 Setting Up the Model Geometry 
 
As shown in Figure 2 above, the model 
geometry is relatively simple.  
 

 
 
Figure 5 Axis/Grid Settings Window 
 
Open the Options menu and select the 
Axis/Grid Settings. Unselect the Axis equal 
button and enter the values shown in Table 6 
below. 

 
 

R min 0.01 
R max 0.085 
Z min -0.002 
Z max 0.003 

 
Table 6 Axis/Grid Values 
 
From the Draw menu, select Specify Objects > 
Rectangle and enter the values shown in Table 
7. 
 

Object R1 
Width (R) 0.06 
Height (Z) 0.001 

Base Corner 
R 0.02 
Z 0 

 
Table 7 Geometry Specifications  
 
2.4 Setting Up the Physics Subdomain 
Settings 
 
In the Multiphysics > Model Navigator select 
Non-Isothermal Flow. Move to the Physics 
menu and select Subdomain Settings > 
Subdomain 1. From Table 8 below, enter the 
parameters as shown under the Physics menu 
button. Figure 6 shows the Non-Isothermal 
Flow Physics Subdomain Window with the 
entered parameters. 
 

Parameter Expression 
" rho_bisn 
# eta_bisn 

kdv 0 
Fr -Sr 
Fz -Sz 

 
Table 8 Non-Isothermal Flow Physics Subdomain 
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Figure 6 Non-Isothermal Flow Physics Subdomain 
Window 
 
Next, click the Init button of the same window 
and enter u_cast in the u(t0) space, as shown in 
Figure 7 below. Click OK. 
 

 
 
Figure 7 Non-Isothermal Flow Physics Subdomain 
Window with the Init button clicked. 
 
Open the Multiphysics > Model Navigator 
select General Heat Transfer. Move to the 
Physics menu and select Subdomain Settings > 
Subdomain 1. From Table 9, enter the 
parameters as shown under the Physics menu 
button. Figure 8 below shows the General Heat 
Transfer Physics Subdomain Window with the 
entered parameters. 
 

Parameter Expression 
k k_bisn 
" rho_bisn 

Cp Cp_bisn+D*dH 
Q 0 

 
Table 9 General Heat Transfer Physics Subdomain 

Click the Init button and enter T_in in the T(t0) 
window. Figure 9 below shows configured Init 
window. 
 

 
 
Figure 8 General Heat Transfer Physics 
Subdomain Conduction 
 

 
 
Figure 9 General Heat Transfer Physics 
Subdomain Init 
 
2.5 Setting Up the Physics Boundary Settings 
 
In the Multiphysics > Model Navigator select 
Non-Isothermal Flow. Move to the Physics 
menu and select Boundary Settings. 
 

Boundary Setting 
1 Laminar inflow 
2 Slip/Symmetry 
3 Slip/Symmetry 
4 Pressure (0) 

 
Table 10 Non-Isothermal Flow Physics Boundary 
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On the Coefficients page, enter the values shown 
in Table 10 above. On the Laminar 
Inflow/Outflow settings page, enter the values 
shown in Table 11 below. 
 

Parameter Expression 
U0 u_cast 
Lini 1e-3 

 
Table 11 Non-Isothermal Flow Physics Boundary 
Laminar Inflow/Outflow Settings 
 

 
 
Figure 10 Non-Isothermal Flow Physics Boundary 
Laminar inflow/Outflow Settings 
 
In the Multiphysics > Model Navigator select 
General Heat Transfer. Move to the Physics 
menu and select Boundary Settings. Insert the 
conditions and expressions as shown in Table 12 
below. 
 

Boundary Setting Expression 
1 Temperature T_in 
2 Thermal 

Insulation 
 

3 Thermal 
Insulation 

 

4 Temperature T_out 
 
Table 12 General Heat Transfer Physics Boundary 
Settings 
 
3. Mesh Generation 
 
Click on the Initialize Mesh button once. Click 
on the Refine Mesh button twice. This should 
yield 2816 elements. 
 
4. Solver Parameters 

 
From the Solve menu, select Solver 
Parameters.  
 

Parameter Setting 
Analysis Stationary 
Solver Parametric 

Name of Parameter dT 
List of Parameter 

Values 
65 21 11 5 2 1 

Linear Solver System Direct(UMFPACK) 
 
Table 13 General Solver Settings 
 

 
 
Figure 11 General Solver Settings 
 
5. Solutions 
 
Click the Solve button and the results should 
arrive in a several seconds. A separate model is 
required for each different material. Run each of 
the five models to arrive at the results shown in 
Table 14 below. 
 
6. Results Analysis 
 

Solder T_trans Radial 
Location 

BiPb(E) 124 0.0692 
BiSn(E) 138 0.0549 

In 157 0.0404 
SnPb(E) 183 0.0283 
SnZn(E) 199 0.0225 

 
Table 14 Phase Transition Radial Location for 
Modeled Materials 
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Table 14 above shows the calculated location of 
the phase transition boundary for the four 
eutectic solder alloys and Indium that resulted 
from the collection of experimental physical 
property values that were inserted into this 
model for those metals.  
 
A first principles test of these calculations can be 
made by comparing the thermal conductivity 
derived from the physical slope of the lines 
between the phase transition point and the two 
boundary points. Figure 12 below shows an 
example of this using the Indium phase transition 
point. 

 
Figure 12 Comparison of Liquid-Solid Thermal 
Conductivity (k) as Modeled. 
 
Reference experimental data sources differ 
(±20%) as to the absolute accuracy of the 
difference in the thermal conductivity across the 
phase transition boundary.  
 
The herein modeled difference agrees well (± 
15%) with reference values available for the 
thermal conductivity for Indium. Model results 
for the other four alloys appear to behave 
consistently with the basic physics involved and 
the Indium reference model. 
 
7. Conclusions 
 

A model has been presented that shows rapid 
convergence and yields calculated results that 
agree with the experimentally available thermal 
conductivity data for Indium to within ± 15%. 
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